Visualg, Exemplo de Programa Usando Vetores


Abaixo você verá um programa que contém vetores, veja o enunciado e logo após o código pronto:

Enunciado:
Crie um vetor e pessa para o usuário gravar 10 números inteiros nele. Depois crie um menu numérico que contenha as opções:
A) Transferir vetor A para B (esse é um outro vetor que você deve criar) e mostrar na tela.
B) Multiplicar o valor de C (um valor determinado pelo usuário) para o vetor A e Mostra-lo na tela.
C) Mostrar na tela os valores dos endereços 7 e 9 do vetor A.
D) Buscar endereço no vetor A por um número digitado pelo usuário, caso o número não exista retorne a ele uma mensagem informando-o.

Código:

algoritmo "Variados de Vetores"
//Josimar Junior E. Criste
//www.informaticode.com.br

var
vet: vetor [1..10] de inteiro
vet2: vetor [1..10] de inteiro
c, mult: real
contador, opcao, numero, cond:inteiro
Inicio
Para contador de 1 ate 10 passo 1 faca
Escreva ("Digite o Valor do Vetor ",contador,":")
Leia(vet[contador])
fimpara
limpatela
escreval("1) Transeferir vetor A para B e mostrar")
escreval("2) Multiplicar o valor de C para o vetor A e Mostra-lo ")
escreval("3) Mostrar na tela os valores do enderecos 7 e 9 do vetor A")
escreval("4) Buscar endereco no vetor A por numero")
escreva("DIGITE UMA OPCAO: ")
leia(opcao)
se (opcao = 1) entao
escreva("Vetor B: ")
Para contador de 1 ate 10 passo 1 faca

vet2[contador] <- vet[contador]
escreva(" ",vet2[contador])

fimpara
escreval("")
escreval("Operacao Completa!")
fimse

se (opcao=2) entao
escreval("De um valor a C: ")
leia(c)

Para contador de 1 ate 10 passo 1 faca
escreval("")
escreva("", c)
escreva(" X ", vet[contador])
mult <- (c*vet[contador])
escreva("= ",mult)
fimpara
escreval("")

escreval("")
escreval("Operacao Completa!")
fimse


se (opcao=3) entao
escreval("Valor do endereco 7: ",vet[7])
escreval("Valor do endereco 9: ",vet[9])
escreval("")
escreval("Operacao Completa!")
 fimse


 se (opcao=4) entao
 cond<-0
 escreval("Digite um número: ")
 leia(numero)
 Para contador de 1 ate 10 passo 1 faca
 se (numero = vet[contador]) entao
 escreval("O numero digitado se encontra no endereco: ", contador)
 cond<-1
 fimse
 fimpara
 se (cond=0) entao
 escreval("O NUMERO REGISTRADO NAO ESTA EM NENHUM ENDERECO!")
 fimse
 fimse



fimalgoritmo

//FIM

Dúvidas? Deixe-a nos comentários!

HOT NA SEMANA

C, Ordenar um Vetor em Ordem Crescente

CSS, Efeito clarear e escurecer em CSS

C, Programa Números em Ordem Crescente

Como Instalar e Rodar Scratch em Celulares e Tablets Com Android







© Copyright 2017 - INFORMATICODE, todos os direitos reservados.