Algoritmo Soma de Números Ímpares

Construa um algoritmo que resolva o problema a seguir:

http://informaticode.blogspot.com.br/p/novos-posts.html
Definir um número inteiro N, que será o número de casos de teste. Cada caso de teste é uma linha que contém dois números inteiros X e Y. O problema se resume em imprimir a soma de todos os valores ímpares entre os dois números inteiros, excetuando-os.

Solução:

algoritmo "Soma de números ímpares"
var
x, y, contador, n, contador2, acumulador: inteiro
inicio
escreval("Digite o número de testes:")
leia(n)
para contador de 1 ate n passo 1 faca
       acumulador <- 0
       escreval("Digite o número X:")
       leia(x)
       escreval("Digite o número Y:")
       leia(y)
       para contador2 de x + 1 ate y - 1 passo 1 faca
              se contador2 % 2 <> 0 entao
                    acumulador <- acumulador + contador2
             fimse
       fimpara
       escreva("Soma dos números ímpares: ")
       escreval(acumulador)
fimpara
fimalgoritmo


Curta nossa página e não deixe de comentar ;)